Heartbleed Vulnerability

News about the Heartbleed Vulnerability has been well covered by pretty much every major media outlet (see the links below if you haven’t heard about it yet), so we will keep this fairly brief:
At this time, a review of our systems has found that none of the servers, sites, or services used by InfoTECH to provide our solutions or secure client data currently utilize the vulnerable OpenSSL implementation. We are taking all appropriate steps to ensure any accounts used by previously vulnerable services are reset. We are encouraging concerned clients to contact our office and schedule a consultation session to review the web applications used by your business so that we can determine the impact that this may have and make recommendations to protect your data.

Comments